PHP, which is a metacronym for PHP: Hypertext Preprocessor, is among the most famous curly-brace programming languages out there. Any site or web app created using PHP will run on a given server as long as a PHP module is installed, which makes the language absolutely universal and it’s not really that surprising that there are actually several million web servers that support it and hundreds of millions of PHP websites hosted on them. PHP is preferred over HTML thanks to the fact that it allows you to develop a responsive website with heaps of options. A PHP-based social networking website, for example, will serve unique web content to each visitor in spite of the fact that the URL will be the same. By contrast, HTML-based sites are static and the content on the pages can be updated only manually. Like any other software program, PHP has several versions and the version that was used while creating a certain website must be activated on the server in order for the site to run flawlessly.

PHP 4 and PHP 5 Support in Shared Website Hosting

Our shared website hosting servers support several versions of PHP, which suggests that your websites will run properly no matter if your scripts are outdated. We realize that an old website doesn’t automatically imply an insecure one as you may have implemented plenty of modifications to its source code. That’s why we support PHP 4, 5.2, 5.3, 5.4 and 5.5 and you can choose which one will be active for your hosting account. The version can be changed with only one single mouse click within your Hepsia Control Panel and the new settings will be applied straight away. If you’d like to run both newer and older scripts, there’s even an option to use a different version of PHP for each of your domains simultaneously.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

Our semi-dedicated plans support multiple versions of PHP, which suggests that you’ll be able to use all the web-based apps that you have set up throughout the years. The Hepsia Control Panel, which comes with every single semi-dedicated server account, will permit you to enable the needed version with one click. You can pick between PHP 5.5, 5.4, 5.3, 5.2 and 4. If you would like to host multiple sites in the exact same account and they have distinctive requirements connected to the hosting environment, you will be able to choose a different PHP version for each of them regardless of which version has been selected for the account as a whole. This is achievable owing to our in-house developed cloud hosting platform, which permits us to run several PHP versions simultaneously. By contrast, most web hosting companies normally support one, in exceptionally rare cases – two versions.